What are the minimum browser requirements to operate e-Profile?

  • Google Chrome preferred
  • Internet Explorer 11, Microsoft Edge, and Safari also acceptable
  • Firefox is not supported